Server Requirements

Server Requirements

Note that Zenbership needs to be installed directly on your web server, therefore services like Wix or Squarespace will NOT work with Zenbership!

These are requirements for your web server. You can confirm these with your web hosting provider or system administrator.

  • FTP or SSH access to your server (to upload the program's files)
  • PHP 5.3+
  • Required Libraries and Extensions:
  • PDO_MySQL
  • mcrypt
  • php curl (for plugins and external connections)
  • Recommended Libraries and Extensions:
  • GD
  • MySQL 5+
  • Recommended: v5.5
  • There are known conflicts with v5.7 that we are working on!

Recommended Configuration

  • Linux-based web hosting
  • Apache or Nginx web server
  • Ability to run cron jobs (scheduled tasks)
  • Without these, you will lose vital functionality.
  • Memory_limit at or above 128Mb (higher is better)
  • Zenbership does work on Windows web servers but is not optimized for them. We recommend a Linux-based server.

Recommended Web Hosting Providers

If you require web hosting, we recommend one of the following providers:

Local Requirements

These are requirements for your local computer, or any computer that will be using Zenbership. Note that while ideally your server should be linux-based, your local computer can run any operating system, including Windows and Mac, as long as these are met:

  • You are using a modern web browser with JavaScript and cookies enabled.
  • We recommend either Chrome 24+, FireFox 18+, Opera 12.1+, Safari 5.1+, or Internet Explorer v10+.
  • Minimum recommend screen resolution of 1024 x 768. Larger resolutions will provide more work space.
  • Note that while the member frontend is mobile-friendly, the Zenbership administrative dashboard is not currently designed to be used with mobile devices!

Article Links

Related Articles

Article Tags

  • No tags found.

Details

Published on 2013/03/29.
Last updated on 2017/02/17.

Was this article helpful?
Yes (0) - No (0)

Share This Article